.comment-link {margin-left:.6em;}

Lothars alter Blog - der neue Blog ist jetzt hier zu finden: http://lotharf.wordpress.com/

Dieser Blog ist leider tot! Google hat ihn nämlich gesperrt; angeblich wegen eines (fälschlichen) Spam Verdachts. Allerdings sind sie anscheinend nicht fähig oder gewillt gewesen, den Fehler zu beheben! Ich habe dem Blog deshalb eine neue Heimstatt gegeben bei Wordpress. Die neue Adresse ist jetzt: http://lotharf.wordpress.com/

Montag, 15. Oktober 2007

Test Suse 10.3 - 2. Teil

Suse läuft zwar bereits, aber es sind noch ein paar Nachinstallations Arbeiten nötig. WLAN funktioniert nicht und die Multimedia Fähigkeiten sind stark eingeschränkt; z.B. spielt keine Video DVD. Dies hat vor allem rechtliche Gründe. Also gehen wir dieses an.
Yast hat eine neue Funktion; unter Software gibt es das neue Verzeichnis "Community Repositories"; dabei handelt es sich um zusätzliche Installationsquellen. Ich wähle aus: ATI Repository (bei Rechnern mit Nvidia Karte: Nvidia Repository), Haupt-Repository OSS, Haupt-Repository Non-Oss, OpenSuse 10.3 Updates, Packman Repository und VideoLAN Repository. Den früher beliebten Guru braucht man übrigens nicht mehr, da dieser ab 10.3 seine Pakete beim Packman veröffentlicht.
Jetzt suche ich erst mal den Treiber für die Atheros AR 5005G WLAN Karte. Ich finde ihn unter http://madwifi.org/suse/10.3/. Unter Installationsquelle wechseln/Hinzufügen binde ich auch dieses Verzeichnis als weitere Installationsquelle "Madwifi" ein. Warum? Werden Pakete nämlich unter Yast aus den Installationsquellen installiert, dann werden die Abhängigkeiten optimal aufgelöst; und zwar über alle Installationsquellen hinweg. Aus dem Madwifi Repository installiere ich den Madwifi Treiber und die Tools. Ein "modprobe ath_pci" lädt den Treiber; mit "iwconfig" wird als neues Gerät ath0 angezeigt; jetzt wird die Karte unter Netzwerkgeräte/Netzwerkkarte mit Yast erkannt und kann konfiguriert werden. Mit den meisten anderen WLAN Chips gibt es dieses Problem übrigens nicht, deren Treiber sind auf der DVD und sie werden auch einwandfrei erkannt.
Jetzt können aus dem ATI Repository die ATI Treiber installiert werden; bei diesem Laptop mit dem einfachen Grafikchip bringt das aber nichts.
Aus dem VideoLan Repository installiere ich den VLC , ffmpeg und die libdvdcss.
Aus dem Packman Repository wähle ich Updates von k3b und kaffeine, sowie die Pakete: libmpeg3, libxine1, xine-ui, MPlayer, rar, transcode und w32codec-all. Viele weitere Pakete, die zur Erfüllung von Abhängigkeiten notwendig sind, werden automatisch ausgewählt und mit installiert.
Das wars. WLAN funktioniert, Multimedia funktioniert einwandfrei, eine Video DVD wird sofort abgespielt.
Wenn man allerdings schon beim Packman drin ist, dann lohnt es sich, das riesige Verzeichnis doch noch etwas genauer anzuschauen, denn es sind dort noch viele ganz feine Progrämmchen drin, die man ja bei dieser Gelegenheit auch gleich mit installieren könnte.
Fazit: OpenSuse 10.3 lässt sich einfach installieren, sieht sehr gut aus, läuft einwandfrei, ist erfreulich schnell, bietet eine riesige Software Auswahl, (fast) alles in deutscher Sprache. Lediglich die nötigen Nachinstallations Arbeiten sind etwas lästig, lassen sich aber relativ einfach durchführen; dank dem einmaligen Yast, einem Werkzeug, mit dem sich das System so übersichtlich und einfach konfigurieren lässt. Suse 10.3 ist derzeit eindeutig die beste Wahl für eine feste Linux Installation, mit der man täglich arbeiten will. Ich kann es nur wärmstens empfehlen.

5 Comments:

At 15 Oktober, 2007 08:18, Anonymous Anonym said...

Danke für den klasse Erfahrungsbericht.

 
At 15 Oktober, 2007 19:14, Anonymous Anonym said...

Ich will jezt keinen Streit vom Zaun brechen, aber ich verstehe nicht, was an Suse so toll sein soll... Mit Synaptic unter Ubuntu kann man software deutlich schneller installieren, und ich find yast allgemein nicht so prickelnd... aber das ist wohl geschmackssache, also jedem das seine... Juhu, am Donnerstag kommt UBUNTU 7.10

 
At 16 Oktober, 2007 01:28, Blogger lothar said...

Na hoffentlich passiert nicht wieder das gleiche wie vor einem Jahr ;-)

 
At 04 November, 2007 19:24, Anonymous Anonym said...

lothar said... Na hoffentlich passiert nicht wieder das gleiche wie vor einem Jahr ;-)


Und was ist voriges Jahr passiert ?

( ich bleibe erstmal bei 10.2)

 
At 06 November, 2007 20:30, Anonymous Anonym said...

Hallo

Habe ein ffmpeg Problem. Version (0.4.9.10872-2.2) unter Suse 10.3 Hab über die obige Quelle installiert. Wenn ich nun ffmpeg aufrufe bekomme ich:
ffmpeg: symbol lookup error: ffmpeg: undefined symbol: sws_getContext

Wollte nun ffmpeg selbst kompilieren und installieren. Da ich aber nix putt machen will, bin ich mir nicht sicher, ob ich das bei Suse einfach machen kann/soll?

Hoffe jemand weiß rat. Hab übrigends ein 64-bit PC.

Grüße und dank im voraus
Pit

 

Kommentar veröffentlichen

Links to this post:

Link erstellen

<< Home